Platformok és nyílt szabványok

A Joomla! bármilyen környezetben futtatható, beleértve a Windowst, a Linux legtöbb változatát, több Unix verziót és az Apple OS/X környezetet. A Joomlának PHP-re és MySQL adatbázisra van szüksége a tartalom dinamikus továbbításához.

A minimális követelmény a következő:

  • Apache 1.x, 2.x vagy újabb
  • PHP 4.3 vagy újabb
  • MySQL 3.23 vagy újabb

Más kiszolgáló környezetben is futtatható, mint a Windows IIS – feltételezve, hogy PHP- és MySQL-támogatással rendelkeznek -, azonban ezeknél további beállításra van szükség, hogy a Joomla! alapcsomag telepítése sikerüljön és működjön.